::: FORUM ManuFrog :::: PHP 5.3 - ::: FORUM ManuFrog :::

Hoppa till innehåll

Sida 1 av 1
  • Du kan inte skapa ett nytt ämne
  • Du kan inte svara i detta ämne

PHP 5.3

#1 Medlemmen är offline   Erik 

  • Administrator
  • PipPipPipPipPipPip
  • Grupp: Admin
  • Inlägg: 7 436
  • Gick med: 13-juli 03

Postad 14 mars 2012 - 22:12

Alla nya servrar installeras med PHP 5.3.xx och övriga servrar kommer uppgraderas från PHP 5.2.xx till PHP 5.3.xx i år om allt går som det är tänkt.

Just nu har vi 3 av servrarna som kör med PHP 5.3.xx – manu31 i USA, manu20 i UK och resell4 i UK.

Ni som har brådskande behov av PHP 5.3.xx ber vi kontakta oss – vi kan flytta Ert konto till en av de servrar som har PHP 5.3.xx.
::: Have great day! //Erik at psychofrog.se and Webbhotell ManuFrog :::
0

#2 Medlemmen är offline   TraXy 

  • Webmaster
  • PipPipPipPipPipPip
  • Grupp: Members
  • Inlägg: 56
  • Gick med: 07-januari 05

Postad 27 augusti 2012 - 10:55

Hej hej! Finns det någon uppdatering vad gäller detta, t.ex. när det förväntas ha genomförts?

Med senaste uppdateringen av phpBB-forum som kom häromdagen så säger de att nästa stora uppdatering kommer att kräva PHP 5.3.2 "eller nyare" - se https://www.phpbb.co...?f=14&t=2152375 för mer info. Nu vet vi ju inte när nästa phpBB-uppdatering kommer, men som admin för ett par phpBB-forum på Manu14-servern så blir jag ju lite nervös när det står 5.2.17 i cPanel och forumen glatt meddelar att min server inte kommer att stödjas i nästa uppdatering.

Vet inte om "inte stödjas" betyder "uppdatera forumet och det slutar funka för 5.2 pallar inte 5.3-specifik kod" eller något annat, men ja. Alltså, i värsta fall så får jag väl låta bli att genomföra nästa forumuppgradering till dess att PHP är uppdaterat på servern, så inte som att vi sitter i sjön här (och jag vill helst inte byta till en annan server eftersom mejl har en tendens att hamna på villovägar under tiden), men det vore ju trevligt om det gick, så att buggfixar och eventuella nya funktioner går att ta del av. :)

Tack på förhand!
0

#3 Medlemmen är offline   Erik 

  • Administrator
  • PipPipPipPipPipPip
  • Grupp: Admin
  • Inlägg: 7 436
  • Gick med: 13-juli 03

Postad 27 augusti 2012 - 19:43

Visa inläggTraXy på 27 augusti 2012 - 10:55 sade:

Hej hej! Finns det någon uppdatering vad gäller detta, t.ex. när det förväntas ha genomförts?

Med senaste uppdateringen av phpBB-forum som kom häromdagen så säger de att nästa stora uppdatering kommer att kräva PHP 5.3.2 "eller nyare" - se https://www.phpbb.co...?f=14&t=2152375 för mer info. Nu vet vi ju inte när nästa phpBB-uppdatering kommer, men som admin för ett par phpBB-forum på Manu14-servern så blir jag ju lite nervös när det står 5.2.17 i cPanel och forumen glatt meddelar att min server inte kommer att stödjas i nästa uppdatering.

Vet inte om "inte stödjas" betyder "uppdatera forumet och det slutar funka för 5.2 pallar inte 5.3-specifik kod" eller något annat, men ja. Alltså, i värsta fall så får jag väl låta bli att genomföra nästa forumuppgradering till dess att PHP är uppdaterat på servern, så inte som att vi sitter i sjön här (och jag vill helst inte byta till en annan server eftersom mejl har en tendens att hamna på villovägar under tiden), men det vore ju trevligt om det gick, så att buggfixar och eventuella nya funktioner går att ta del av. :)

Tack på förhand!


Hej!

Vårt mål är att alla servrar ska ha PHP 5.3.xx innan året är slut. Jag hoppas vi kan återkomma med en plan så snart som möjligt.
::: Have great day! //Erik at psychofrog.se and Webbhotell ManuFrog :::
0

#4 Medlemmen är offline   TraXy 

  • Webmaster
  • PipPipPipPipPipPip
  • Grupp: Members
  • Inlägg: 56
  • Gick med: 07-januari 05

Postad 27 augusti 2012 - 21:13

Visa inläggErik på 27 augusti 2012 - 19:43 sade:

Hej!

Vårt mål är att alla servrar ska ha PHP 5.3.xx innan året är slut. Jag hoppas vi kan återkomma med en plan så snart som möjligt.


Åh, trevligt! Årets slut är ju inte såååå långt bort ändå. :) Tack för svaret!
0

#5 Medlemmen är offline   Erik 

  • Administrator
  • PipPipPipPipPipPip
  • Grupp: Admin
  • Inlägg: 7 436
  • Gick med: 13-juli 03

Postad 05 oktober 2012 - 13:24

Lite info inför uppgraderingarna till PHP 5.3.xx

En del äldre php-skript är inte kompatibla med php 5.3.xx så när vi uppgraderat till php 5.3.xx kan dessa sluta fungera som de ska.
Exempel på felmeddelanden kan vara:

Citat

PHP Deprecated: Function eregi() is deprecated in


För att lösa detta måste php-skripten uppgraderas till en senare (nyare) version - och detta är något som borde ha utförts tidigare då det oftast handlar om mycket gamla versioner (flera år) som har mängder med säkerhetshål och buggar.

De PHP-skript som använder sig av Zend kan också få problem då det är en annan/ny version av Zend i PHP 5.3.xx och de PHP-skript som har filer med krypterad kod utförd av gamla Zend kommer då inte längre kunna läsas vilket kan innebär att felmeddelanden som tex följande visas:

Citat

Fatal error: Incompatible file format: The encoded file has format major ID 3, whereas the Loader expects 4


För att lösa detta måste php-skriptet uppgraderas till en senare (nyare) version - och det bör alla skript-utvecklare vara medvetna om eftersom PHP 5.2.xx övergavs av utvecklarna för över ett år sedan.

Före PHP 5.3.xx var det Zend Optimizer som gällde - efter PHP 5.3.xx är det Zend Guard som gäller.

Ett alternativ kan vara om PHP skriptet även finns i en version som använder sig av IonCube.

Magic Quotes kommer inaktiveras men kan aktiveras om Ni använder en php.ini fil (se följande tråd) men i version 5.4 försvinner Magic Quotes helt och hållet så då går det ej längre att aktivera/använda.
Så har man skript som fortfarande kräver detta bör man snarast se om det finns en uppgradering.
::: Have great day! //Erik at psychofrog.se and Webbhotell ManuFrog :::
0

#6 Medlemmen är offline   peranders 

  • Superior Member
  • PipPipPipPipPip
  • Grupp: Members
  • Inlägg: 17
  • Gick med: 03-juni 08

Postad 14 november 2012 - 21:10

När kan manu14 ha php 5.3 tror du? Jag ska köra Joomla 3 som kräver 5.3.
0

#7 Medlemmen är offline   Erik 

  • Administrator
  • PipPipPipPipPipPip
  • Grupp: Admin
  • Inlägg: 7 436
  • Gick med: 13-juli 03

Postad 14 november 2012 - 23:10

Visa inläggperanders på 14 november 2012 - 21:10 sade:

När kan manu14 ha php 5.3 tror du? Jag ska köra Joomla 3 som kräver 5.3.


Hej !

Nu i helgen uppgraderas manu 16,17,18 och 19 så manu14-servern står på tur helgen efter denna om allt går som planerat.
::: Have great day! //Erik at psychofrog.se and Webbhotell ManuFrog :::
0

#8 Medlemmen är offline   peranders 

  • Superior Member
  • PipPipPipPipPip
  • Grupp: Members
  • Inlägg: 17
  • Gick med: 03-juni 08

Postad 15 november 2012 - 06:37

Vad härligt. Då kan jag beställa ytterligare ett konto hos dig.
0

Dela med dig av detta ämne:


Sida 1 av 1
  • Du kan inte skapa ett nytt ämne
  • Du kan inte svara i detta ämne


1 användare läser detta ämne
0 medlemmar, 1 gäster, 0 anonyma medlemmar