::: FORUM ManuFrog :::: PHPsuexec - ::: FORUM ManuFrog :::

Hoppa till innehåll

Sida 1 av 1
  • Du kan inte skapa ett nytt ämne
  • Du kan inte svara i detta ämne

PHPsuexec

#1 Guest_Guest_Packe_*

  • Grupp: Guests

Postad 19 april 2006 - 07:55

Hallå,

Försöker få mitt webmail-script att fungera efter att PHPsuexec har slagits på. Tycker mig ha följt instruktionerna men får inte upp sidan. Det konstiga är att jag inte får några felmeddelande utan hamnar på index-sidan för "huvudsidan" istället för index-sidan för webmailen.

Går till webmail.wakaba.se -> www.wakaba.se/roundcube/index.php men visar www.wakaba.se/index.php.

Vad har jag missat?
0

#2 Medlemmen är offline   Pezzen 

  • Moderator
  • PipPipPipPipPipPip
  • Grupp: Moderator
  • Inlägg: 153
  • Gick med: 30-januari 04

Postad 19 april 2006 - 13:20

Har du lagt till webmail som en underdomän?
Har du av misstag lagt till en redirecrion på underdomänen eller någon annanstans?
Regards
Stefan/Pezzen
0

#3 Guest_Guest_Packe_*

  • Grupp: Guests

Postad 19 april 2006 - 14:35

Det finns en underdomän sedan tidigare och inga förändringar har gjorts på bra länge. Det fungerade som tänkt igår.
0

#4 Medlemmen är offline   Pezzen 

  • Moderator
  • PipPipPipPipPipPip
  • Grupp: Moderator
  • Inlägg: 153
  • Gick med: 30-januari 04

Postad 19 april 2006 - 15:37

Men både www.wakaba.se/roundcube/index.php och www.wakaba.se/index.php visar samma sida?
Regards
Stefan/Pezzen
0

#5 Guest_Guest_Packe_*

  • Grupp: Guests

Postad 19 april 2006 - 18:43

Nu visas samma sida, så har det inte varit tidigare.
0

#6 Medlemmen är offline   Erik 

  • Administrator
  • PipPipPipPipPipPip
  • Grupp: Admin
  • Inlägg: 7 561
  • Gick med: 13-juli 03

Postad 19 april 2006 - 21:47

Du har troligen några "rewrite" regler i .htaccess filer som inte fungerar ihop med phpsuexec.

Tex. så finns ju exemplet med Joomla's .htaccess-fil. http://forum.psychofrog.se/index.php?showt...t=16&#entry3649

Du vill antagligen att man ska hamna på Cpanel's webmail om man skriver http://webmail.wakaba.se ?
Som standard kan webmailen alltid nås via http://www.wakaba.se/webmail
::: Have great day! //Erik at psychofrog.se and Webbhotell ManuFrog :::
0

#7 Guest_Guest_Packe_*

  • Grupp: Guests

Postad 20 april 2006 - 06:54

Stämmer att .htacess var källan till problemet. Nu tog jag helt enkelt bort den och då var det inga problem längre.
0

#8 Medlemmen är offline   Erik 

  • Administrator
  • PipPipPipPipPipPip
  • Grupp: Admin
  • Inlägg: 7 561
  • Gick med: 13-juli 03

Postad 22 april 2006 - 18:38

Tänkte det är bäst jag postar lite mer om .htaccess och phpsuexec.

Ett exempel är Gallery 1 som använder sig av .htaccess filen för att bilder och länkar ska fungera.
Ett exempel på hur en .htaccess-fil kan se ut:
# BEGIN Gallery section
# (Automatically generated.  Do not edit this section)
# Note: still under development, so format may change.
# If you edit this file, make a backup before runnng the Config. Wizard.


php_value post_max_size 20971520
php_value upload_max_filesize 20971520
php_value magic_quotes_gpc off
php_value session.save_handler files
php_value register_globals off

Options -Indexes +FollowSymLinks
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /gallery/

RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^\.\?/]+)/([0-9]+)$	/gallery/view_photo.php?set_albumName=$1&index=$2	[QSA]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^\.\?/]+)/([A-Za-z_0-9\-]+)$	/gallery/view_photo.php?set_albumName=$1&id=$2	[QSA]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^\.\?/]+)/$	/gallery/$1	[R]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^\.\?/]+)$	/gallery/view_album.php?set_albumName=$1	[QSA]
</IfModule>
# END Gallery section.  Add User changes below this line


Om det ser ut så i .htaccess filen, kommer Gallery ge felmeddelande eller så visas tex. inga bilder.
Skapa en fil med namnet "php.ini" och klistra in koden från .htaccess-filen. Man kan använda "anteckningar" i Windows. (skapa en textfil, kopiera textraderna i .htaccess-filen och spara sedan filen med namnet "php.ini".)

Sedan måste .htaccess filen redigeras. Lägg till tecknet # framför raderna med "reglerna/instruktionerna" för php, så här:
# BEGIN Gallery section
# (Automatically generated.  Do not edit this section)
# Note: still under development, so format may change.
# If you edit this file, make a backup before runnng the Config. Wizard.


#php_value post_max_size 20971520
#php_value upload_max_filesize 20971520
#php_value magic_quotes_gpc off
#php_value session.save_handler files
#php_value register_globals off

Options -Indexes +FollowSymLinks
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /gallery/

RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^\.\?/]+)/([0-9]+)$	/gallery/view_photo.php?set_albumName=$1&index=$2	[QSA]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^\.\?/]+)/([A-Za-z_0-9\-]+)$	/gallery/view_photo.php?set_albumName=$1&id=$2	[QSA]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^\.\?/]+)/$	/gallery/$1	[R]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^\.\?/]+)$	/gallery/view_album.php?set_albumName=$1	[QSA]
</IfModule>
# END Gallery section.  Add User changes below this line


Detta löser problemet med felmeddelandet.

Dock kan det finnas mappar som har rättighet "777", vilket ger felmeddelanden - ändra dessa till "755" så kommer det fungera.
Kan Du ej ta bort eller ändra en bild/fil? Då har troligen filen ägare "nobody" vilket den inte längre kan ha, den måste få ägare "kontonamn" för att det ska fungera.

Man kan åtgärda detta själv genom att via Ftp tanka hem filen, sedan radera den från servern, och skicka upp den igen från sin dator - då får den ägare "kontonamn".
Annars kan man kontakta oss så får vi byta ägare på filerna. (rekommenderas om man har många filer)
::: Have great day! //Erik at psychofrog.se and Webbhotell ManuFrog :::
0

#9 Medlemmen är offline   zyko 

  • Rookie
  • PipPip
  • Grupp: Members
  • Inlägg: 4
  • Gick med: 12-augusti 05

Postad 23 april 2006 - 13:04

Tack för guiden, sparade mig många timmar!
Tidigare hade jag även gZip aktiverat i gallery, med följande rader i .htaccess:

php_flag output_buffering On
php_value output_handler ob_gzhandler
php_flag zlib.output_compression Off

är det möjligt att aktivera gZip i php.ini?

MVH zyko
0

#10 Medlemmen är offline   Micke 

  • VIP Member
  • PipPipPipPipPipPip
  • Grupp: Members
  • Inlägg: 92
  • Gick med: 14-mars 05

Postad 23 april 2006 - 18:39

Innebär det där att min Wordpress kommer att sluta funka nu när jag är borta till veckan då iom ni skall köra igång detta på tis 25/4 på Manu4?

För htaccess-filen är ju fullmatad i WP om man använder permalänkar. Bara lite nyfiken men blir det så, så blir det ju bara :)
0

#11 Medlemmen är offline   Erik 

  • Administrator
  • PipPipPipPipPipPip
  • Grupp: Admin
  • Inlägg: 7 561
  • Gick med: 13-juli 03

Postad 23 april 2006 - 23:37

Citat

är det möjligt att aktivera gZip i php.ini?

Ja, det ska gå bra. Testa isåfall till att skriva:
output_buffering On
output_handler ob_gzhandler
zlib.output_compression Off


När det gäller

Citat

För htaccess-filen är ju fullmatad i WP om man använder permalänkar

så är det troligtvis så att Din Wordpress kommer få problem isåfall. :)
Om Du är bortrest kanske vi kan hjälpa till? Bara att maila oss isåfall.

Själv kör jag Wordpress på en server med PHPsuexec aktiverat, och det fungerar utmärkt. (t.o.m bättre tycker jag) Ingen .htaccess-fil eller php.ini-fil används dock. (Använder WordPress 2.0.2 med "Permalinks Default" = exempel: "http://domännamn.se/?p=123")
::: Have great day! //Erik at psychofrog.se and Webbhotell ManuFrog :::
0

#12 Medlemmen är offline   theoo 

  • Member
  • PipPipPip
  • Grupp: Members
  • Inlägg: 5
  • Gick med: 17-december 05

Postad 25 april 2006 - 12:31

Hej Erik

Min WP-installation verkar inte fungera så bra.

När jag kör nånting som ligger i WP-installationen, så får jag endast upp en vit sida.
Har försök att ändra alla rättigheter som jag ser, (på både mappar och filer)
Jag läste någonstans att ägaren på filerna kanske måste ändras. Hur ser jag det?

Min sida finns på 72.29.82.190/~theoo/index.php och WP ligger under 72.29.82.190/~theoo/sollentunakanot/index.php


PS. WP-installationen är uppladdad med FTP, och inte med Fantastico. DS.
0

#13 Medlemmen är offline   theoo 

  • Member
  • PipPipPip
  • Grupp: Members
  • Inlägg: 5
  • Gick med: 17-december 05

Postad 25 april 2006 - 13:09

theoo på 25 Apr 2006, 12:31 sade:

Hej Erik

Min WP-installation verkar inte fungera så bra.
.....

Det verkar som att det va WPs cachefiler som ställde till det.

Efter att jag raderat dem så fungerar sidan igen :)
0

#14 Medlemmen är offline   Erik 

  • Administrator
  • PipPipPipPipPipPip
  • Grupp: Admin
  • Inlägg: 7 561
  • Gick med: 13-juli 03

Postad 25 april 2006 - 18:25

Citat

Det verkar som att det va WPs cachefiler som ställde till det.

Efter att jag raderat dem så fungerar sidan igen smile.gif


Hej! Troligen finns det filer som har ägare "nobody". Då kan det blir tokigt. Man kan då ladda hem filerna, och sedan radera dom på sitt konto - och sedan skicka upp dom från sin dator till sitt konto.
Då får de rätt ägare, det vill säga "theoo".

Om Du vill kan jag "chowna" alla Dina filer så alla får rätt ägare. Var snäll och maila oss isåfall.

(Det är inte alla Ftp-program som visar vilken ägare filen har tyvärr)
::: Have great day! //Erik at psychofrog.se and Webbhotell ManuFrog :::
0

#15 Medlemmen är offline   armen 

  • Rookie
  • PipPip
  • Grupp: Members
  • Inlägg: 3
  • Gick med: 02-januari 06

Postad 12 maj 2006 - 16:19

tidigare så fanns det en tråd om wap, hittade dock inte den.
men hur skriver man i php.ini för att göra så att .wml tolkas som .php filer???
i .htaccess filer så skriver man
AddType application/x-httpd-php .wml

hur gör man då detta i php.ini???
0

#16 Medlemmen är offline   Erik 

  • Administrator
  • PipPipPipPipPipPip
  • Grupp: Admin
  • Inlägg: 7 561
  • Gick med: 13-juli 03

Postad 12 maj 2006 - 20:59

armen på 12 May 2006, 17:19 sade:

tidigare så fanns det en tråd om wap, hittade dock inte den.
men hur skriver man i php.ini för att göra så att .wml tolkas som .php filer???
i .htaccess filer så skriver man
AddType application/x-httpd-php .wml

hur gör man då detta i php.ini???

Det behöver ändras lite, men reglerna/koden ska fortfarande vara i .htaccess-filen - inte i php.ini filen:

AddHandler application/x-httpd-php .wml


Var snäll och testa det.
::: Have great day! //Erik at psychofrog.se and Webbhotell ManuFrog :::
0

Dela med dig av detta ämne:


Sida 1 av 1
  • Du kan inte skapa ett nytt ämne
  • Du kan inte svara i detta ämne


1 användare läser detta ämne
0 medlemmar, 1 gäster, 0 anonyma medlemmar